Started 6 days agoJuly 15, 2026Lasted 9 minutesJuly 15, 20262:092:18 PMUTC
Affected
VPS Hosting
Under maintenance from 2:09 PM to 2:18 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Identified
UTC
Identified
UTC
We will be carrying out an emergency reboot of VM-VPS01-THN in London at around 15:08 BST. VMs may be offline for around 10-15 minutes whilst this is carried out. We apologise for any inconvenience caused.